Ticket #202 (closed enhancement: fixed)
Revise Coding Conventions; Define Coding Style Guidelines
|Reported by:||UdoBorkowski||Owned by:||MartinBudden|
Revise the existing coding conventions for core code.
At least the following aspects should be covered:
- The guidelines should allow space efficient writing style (to keep the core code small). This may be affected by revised bracing and indentation rules. Also consider naming conventions for (parameter/variable) names (e.g. use "tid" (or "t") instead of "tiddler", write "date" instead of "theDate" etc.)
- Use (variable) names consistently (i.e. defining naming conventions). E.g. make it easier to differentiate a variable holding a "Tiddler" object from one that holds a "tiddler title" or one that holds either a Tiddler object or tiddler title.
The new coding conventions should be applied for new code directly, and incrementally for "old code".